Search Gradle plugins

Version 6.0.2-alpha

Created 30 July 2021.

Gosu language compiler for Gradle. Built with Gradle 6.5.1.

This has also been tested extensively with Gradle version(s): 6.5.1

** Gradle versions below 2.12 are no longer supported **

Projects applying this plugin require a compile-time dependency on the gosu-core-api library.

This version requires Gosu 1.13.9 or greater, or 1.14.2 or greater.

Please include this in the depencencies closure:

dependencies {
compile group: 'org.gosu-lang.gosu', name: 'gosu-core-api', version: '1.14.23-SNAPSHOT'
}

Using the plugins DSL:

plugins {
  id "org.gosu-lang.gosu" version "6.0.2-alpha"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "org.gosu-lang.gosu:gradle-gosu-plugin:6.0.2-alpha"
  }
}

apply plugin: "org.gosu-lang.gosu"

Using the plugins DSL:

plugins {
  id("org.gosu-lang.gosu") version "6.0.2-alpha"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("org.gosu-lang.gosu:gradle-gosu-plugin:6.0.2-alpha")
  }
}

apply(plugin = "org.gosu-lang.gosu")

Learn how to apply plugins to subprojects