Search Gradle plugins

Version 5.0.1

Created 04 March 2017.

SpongeAPI code generation for events

Using the plugins DSL:

plugins {
  id "org.spongepowered.event-impl-gen" version "5.0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.org.spongepowered:event-impl-gen:5.0.1"
  }
}

apply plugin: "org.spongepowered.event-impl-gen"

Using the plugins DSL:

plugins {
  id("org.spongepowered.event-impl-gen") version "5.0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.org.spongepowered:event-impl-gen:5.0.1")
  }
}

apply(plugin = "org.spongepowered.event-impl-gen")

Learn how to apply plugins to subprojects