Search Gradle plugins

Version 5.5.0

Created 17 February 2019.

SpongeAPI code generation for events

Using the plugins DSL:

plugins {
  id "org.spongepowered.event-impl-gen" version "5.5.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.org.spongepowered:event-impl-gen:5.5.0"
  }
}

apply plugin: "org.spongepowered.event-impl-gen"

Using the plugins DSL:

plugins {
  id("org.spongepowered.event-impl-gen") version "5.5.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.org.spongepowered:event-impl-gen:5.5.0")
  }
}

apply(plugin = "org.spongepowered.event-impl-gen")

Learn how to apply plugins to subprojects