Search Gradle plugins

Version 0.9.0 (latest)

0.9.0

Created 27 August 2018.

This plugin version will no longer resolve after JCenter becomes a permanent redirect to Maven Central as it uses dependencies only found in JCenter. See the following blog post for details: https://blog.gradle.org/portal-jcenter-impact Gradle plugin providing integration for plugins made for the Sponge platform

Using the plugins DSL:

plugins {
  id("org.spongepowered.plugin") version "0.9.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.org.spongepowered:spongegradle:0.9.0")
  }
}

apply(plugin = "org.spongepowered.plugin")

Using the plugins DSL:

plugins {
  id "org.spongepowered.plugin" version "0.9.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.org.spongepowered:spongegradle:0.9.0"
  }
}

apply plugin: "org.spongepowered.plugin"

Learn how to apply plugins to subprojects