Search Gradle plugins

Version 1.0.3 (latest)

Created 20 July 2018.

Gradle plugin that provides tasks for bundling deployment descriptors for AWS EB update

Using the plugins DSL:

plugins {
  id "io.townsq.aws-eb-docker-bundle" version "1.0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.io.townsq:gradle-plugins:1.1.6"
  }
}

apply plugin: "io.townsq.aws-eb-docker-bundle"

Using the plugins DSL:

plugins {
  id("io.townsq.aws-eb-docker-bundle") version "1.0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.io.townsq:gradle-plugins:1.1.6")
  }
}

apply(plugin = "io.townsq.aws-eb-docker-bundle")

Learn how to apply plugins to subprojects