Search Gradle plugins

Version 6.1.0 (latest)

6.1.0

Created 13 May 2024.

This plugin should be applied to Intershop Commerce Management customer projects.

Using the plugins DSL:

plugins {
  id("com.intershop.gradle.icm.project") version "6.1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.intershop.gradle.icm:icm-gradle-plugin:6.1.0")
  }
}

apply(plugin = "com.intershop.gradle.icm.project")

Using the plugins DSL:

plugins {
  id "com.intershop.gradle.icm.project" version "6.1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.intershop.gradle.icm:icm-gradle-plugin:6.1.0"
  }
}

apply plugin: "com.intershop.gradle.icm.project"

Learn how to apply plugins to subprojects