Search Gradle plugins

Version 0.17.0

Created 05 November 2021.

- Increase the length of plugin version strings to a maximum of 50 characters
- Abort publishing if a plugin version is specified as a SNAPSHOT

Using the plugins DSL:

plugins {
  id "com.gradle.plugin-publish" version "0.17.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.gradle.publish:plugin-publish-plugin:0.17.0"
  }
}

apply plugin: "com.gradle.plugin-publish"

Using the plugins DSL:

plugins {
  id("com.gradle.plugin-publish") version "0.17.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.gradle.publish:plugin-publish-plugin:0.17.0")
  }
}

apply(plugin = "com.gradle.plugin-publish")

Learn how to apply plugins to subprojects