Search Gradle plugins

Version 1.0.133 (latest)

Created 19 May 2019.

Plugin that executes SonarLint checks without SonarQube server. Min Gradle version: 4.5.

Using the plugins DSL:

plugins {
  id "name.remal.sonarlint" version "1.0.133"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "name.remal:gradle-plugins:1.0.133"
  }
}

apply plugin: "name.remal.sonarlint"

Using the plugins DSL:

plugins {
  id("name.remal.sonarlint") version "1.0.133"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("name.remal:gradle-plugins:1.0.133")
  }
}

apply(plugin = "name.remal.sonarlint")

Learn how to apply plugins to subprojects