Search Gradle plugins

Version 0.56.0 (latest)

Created 02 December 2023.

Automated Quality Assurance configuration for Kotlin Projects built with Gradle

Using the plugins DSL:

plugins {
  id("org.danilopianini.gradle-kotlin-qa") version "0.56.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("org.danilopianini:gradle-kotlin-qa:0.56.0")
  }
}

apply(plugin = "org.danilopianini.gradle-kotlin-qa")

Using the plugins DSL:

plugins {
  id "org.danilopianini.gradle-kotlin-qa" version "0.56.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "org.danilopianini:gradle-kotlin-qa:0.56.0"
  }
}

apply plugin: "org.danilopianini.gradle-kotlin-qa"

Learn how to apply plugins to subprojects