Search Gradle plugins

Version 5.2.1 (latest)

Created 07 August 2019.

A software composition analysis plugin that identifies known vulnerable dependencies used by the project.

Using the plugins DSL:

plugins {
  id "org.owasp.dependencycheck" version "5.2.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "org.owasp:dependency-check-gradle:5.2.1"
  }
}

apply plugin: "org.owasp.dependencycheck"

Using the plugins DSL:

plugins {
  id("org.owasp.dependencycheck") version "5.2.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("org.owasp:dependency-check-gradle:5.2.1")
  }
}

apply(plugin = "org.owasp.dependencycheck")

Learn how to apply plugins to subprojects