Search Gradle plugins

com.zegreatrob.jsmints.plugins.ncu

This plugin provides tasks for using the npm-check-updates npm program, for updating package.json dependencies when using Kotlin JS.

https://github.com/robertfmurdock/jsmints

Sources: https://github.com/robertfmurdock/jsmints

Version 6.1.6 (latest)

6.1.6

Created 16 July 2024.

This plugin provides tasks for using the npm-check-updates npm program, for updating package.json dependencies when using Kotlin JS.

Using the plugins DSL:

plugins {
  id("com.zegreatrob.jsmints.plugins.ncu") version "6.1.6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.zegreatrob.jsmints:plugins:6.1.6")
  }
}

apply(plugin = "com.zegreatrob.jsmints.plugins.ncu")

Using the plugins DSL:

plugins {
  id "com.zegreatrob.jsmints.plugins.ncu" version "6.1.6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.zegreatrob.jsmints:plugins:6.1.6"
  }
}

apply plugin: "com.zegreatrob.jsmints.plugins.ncu"

Learn how to apply plugins to subprojects